
IoT 4:
ESP8266, Arduino 
and NeoPixels

P. Blythe, SPCS EITP F3 2017-18



Previously...

You know how to send a receive data by HTTP, and how to link 
different services and apps together using IFTTT. This is the 
software knowledge you need to make an IoT device.

Now, we move on to hardware.



The ESP8266

The ESP8266 is an incredibly useful little chip, and is the 
favourite platform of individual makers and big companies 
alike when it comes to making IoT devices. If you have an 
internet-connected home device, there’s a good chance 
there’s an ESP8266 chip inside it.

It’s cheap. It has a fairly fast processor. It has programmable 
inputs (for sensing) and outputs (for making things happen). 
Importantly, for us, it has WiFi.

Most importantly of all, it’s very well documented and 
supported online.



The ESP8266

The ESP8266 board we are using is the Adafruit Feather 
Huzzah. 

It’s more expensive than some (HK$140), but it includes USB 
connection for easy programming, a good power supply 
system and lots of documentation. 

See what people use it for:
https://www.hackster.io/adafruit/products/adafruit-feather-huzzah-with-esp8266-wifi

Adafruit is an interesting company itself - named after its 
founder’s nickname, LadyAda, who was inspired by Ada 
Lovelace - “the world’s first computer programmer”.

https://www.hackster.io/adafruit/products/adafruit-feather-huzzah-with-esp8266-wifi


Arduino

Arduino is the most popular system for home programming of 
microcontrollers - simple processors that are great for 
controlling robots, switching on and off lights, making 
animated displays and so on.

Nearly every “I have a cool robot” project you’ve ever seen has 
been Arduino-based.

Microcontrollers are very simple compared to a “proper” 
computer. They don’t run very fast. They don’t run an 
operating system. They run one programme at a time. But 
they are very reliable and very predictable - just what you 
need for automation.



Arduino

The Arduino ecosystem includes both hardware and software. 
It’s also open-source. You can make both hardware and 
software which is compatible with the system yourself, for 
free.

The official website includes lots of tutorials and 
documentation - go and have a look now:

https://www.arduino.cc/ 

The ESP8266 is not officially supported by Arduino, but 
people have developed ways to make it work. That makes 
programming the ESP8266 is much easier.

https://www.arduino.cc/


Setup

We need to install several things to set up our development 
environment. Follow each step carefully!

Additional note: If you are not using an ESP8266, use the following settings instead of 
those indicated. You should set:

Arduino Uno - Board: Arduino Uno. #define PIN 6, use pin 6 for data line to Neopixels

Arduino Mega - Board: Arduino Mega  2560,  #define PIN 6, use pin 6 for data line to 
Neopixels

Wemos D1 - Board: Wemos D1,  #define PIN D8, use pin D8 for data line to Neopixels 
- make sure to set upload speed to 115200. Download and install CHG340 driver 
from https://sparks.gogo.co.nz/ch340.html 

https://sparks.gogo.co.nz/ch340.html


Install Drivers

Most of our laptops already have this driver since the robotics 
module, but if yours doesn’t, or you aren’t sure then download 
and install it.

Download and install the Silicon Labs CP210x driver from
https://www.silabs.com/products/development-tools/softwa
re/usb-to-uart-bridge-vcp-drivers 

You will need to extract the .zip file and run the setup program 
inside.

https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers


First, download the latest version of the Arduino development environment from:
https://www.arduino.cc/en/Main/Software

Download the Windows Installer, not the Windows 10 App, and run it.

You may be asked to uninstall a previous version. That’s fine, you can allow it. Agree 
to the default options. Don’t change them!

https://www.arduino.cc/en/Main/Software


We need to add support for the ESP8266 to the Arduino software.

First, start Arduino. Then go to File → Preferences.

Near the bottom is a box labelled Additional Boards Manager URLs.

Copy this address and paste it into the box, then click OK:
http://arduino.esp8266.com/stable/package_esp8266com_index.json

http://arduino.esp8266.com/stable/package_esp8266com_index.json


That has told the Arduino 
software where to find the 
information it needs. Now we 
need to actually install it.

Go to Tools → Board → Boards 
Manager in the Arduino menus.

Your menus might look slightly 
different - mine already has the 
support installed - but the 
options will be there!



Scroll to the bottom of the list. 

Click on the esp8266 section to make the Install button appear.

Click Install. Wait for it to install, then close.



Now we need to set up the Arduino 
software so it knows what kind of 
board we are using.

Go to Tools → Board → Adafruit 
Feather HUZZAH ESP8266 and 
select it.

You may have to scroll down the list 
of boards to find it, using the small 
arrow at the bottom of the list.

You should also check these settings 
in the same menu:
Flash Size: “4M (1M SPIFFS)”
CPU Frequency: “80 MHz”
Upload Speed: “115200”

They’re probably correct, but it’s 
worth making sure.



To test if everything is working, we will run the Arduino 
equivalent of a “Hello, world” program - Blink.

Go to File → Examples → 01.Basics → Blink

This loads the Blink program. It’s fairly simple, but we’ll 
explain how it works later.

Plug in your Feather Huzzah to the laptop with a USB cable.

Go to Tools → Port → COMn where n is a number, probably 3 
or 4. 

This is the COM port your board is communicating on. If you have more than one 
choice, try one and then if it doesn’t work, change it.

Our first Arduino program



Click the right-arrow (Upload) at 
the top left of the window.

This will first compile the program 
(turn it into machine code for the 
processor on your board) and 
then upload it to the processor.

This can be a slow process - one 
or two minutes - the first time 
you run it.

Messages will appear in the black 
box at the bottom of the window. 
You can make this bigger by 
dragging the border upwards.



Try these steps, trying again after each step.

1. Choose another COM port.
2. Reload the Blink program from the menu, in case you 

accidentally typed something.
3. Download and install the Silicon Labs CP210x driver 

from
https://www.silabs.com/products/development-tools/so
ftware/usb-to-uart-bridge-vcp-drivers 
Then restart Arduino and choose the COM port again.

If you can’t upload

https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers


If it works

You should be able to see a faint blue LED flashing very 
quickly while the program is being uploaded.

Once the programme is running, a red LED on the Feather 
Huzzah should slowly turn on and off.

If this is working, congratulations! You are an Arduino 
programmer!

If not, ask for help. You are not an Arduino programmer. Yet.



Arduino programming

First, have a look at the Blink program. Can you see what it 
does?

All Arduino programs have these two functions:

setup() - runs once when the program starts

loop() - runs in a loop forever after setup has finished

The setup() function is used in this program for putting one 
of the output pins into the correct mode.

The loop() function turns the LED on by turning the output 
pin to be HIGH (on, 3.3 V), waits a second, then turns it LOW 
(off, 0 V), and waits another second.



Challenge 1

Can you modify the Blink program so that the light blinks 
faster? Can you make it blink different patterns?



Things to notice - semicolons and 
brackets

Command lines all end with a semicolon    ;
Functions use curly brackets { } to show where they start and 
end:

void myfunction(){
somecommand;
some_other_command(2);

}

*The ‘void’ keyword indicates that the function does not return any value when 

it is called. You don’t need to worry about it for now.



Things to notice - semicolons and 
brackets

Functions use round brackets for taking in parameters. The 
parameters are separated by commas.

void myfunction(age, name, height){
print(height);
if (age>25) {

print(“ur so old lol”) //comment
}

}

Comments are made by typing a double-slash // - they can be 
made on the same line as a command



Things to notice - white space

Unlike Python, white space (spaces, line returns, tabs) doesn’t 
matter in Arduino. The structure information comes from 
using brackets and semicolons.

void myfunction(age, name, height){
→ print(height);
→ if (age>25) {
→ → print(“ur so old lol”) //comment
→ }
}

But it’s still a good idea to follow indentation rules. It makes 
your code much easier to read and debug.



NeoPixels

We are going to learn how to program NeoPixels.

NeoPixels are LEDs, with a few special features.

Usually, LEDs are a single colour. You buy the colour you want.

Usually, you need to connect each LED separately. Every extra 
LED needs an extra wire and an extra output pin on the chip

NeoPixels solve both these problems.

More:
https://learn.adafruit.com/adafruit-neopixel-uberguide/the-magic-of-neopixels

https://makezine.com/tag/neopixel/ 

https://learn.adafruit.com/adafruit-neopixel-uberguide/the-magic-of-neopixels
https://makezine.com/tag/neopixel/


NeoPixels

NeoPixels are three (or four - red, green, blue and sometimes 
white) LEDs in one package, with a tiny processor attached. 
You can connect them in a long line and they will work out 
what order they are connected in.

They need just three wires to control hundreds of LEDs: 
Power (5 V), ground (0 V) and a data wire that sends 
commands.

So you can write a program that says “turn pixel 50 red, half 
brightness” or “turn pixel 12 off”. You can update the colours 
hundreds of times a second to make smooth animations.



Installing Neopixel libraries

There is a NeoPixel library for Arduino that gives us lots of 
functions we can use to control them.

Download from Github:

https://github.com/adafruit/Adafruit_NeoPixel

Click Clone or download

Then Download ZIP

https://github.com/adafruit/Adafruit_NeoPixel


Installing Neopixel libraries

The file you downloaded will be called 
Adafruit_NeoPixel-master.zip. Double-click the .zip file and 
then “Extract all”.

The .zip will be extracted to a folder called 
“Adafruit_NeoPixel-master”. Inside that folder is another one 
called “Adafruit_NeoPixel-master” again.

Rename this inner folder to “Adafruit_NeoPixel”. Then select 
it, copy it and paste the copy into:

C:\Program Files (x86)\Arduino\libraries\

Quit and restart Arduino.



WARNING!

GETTING THE WIRING WRONG COULD:

BLOW UP THE NEOPIXELS
BLOW UP THE ESP8266

OVERHEAT THE CHIPS AND BURN YOU
DAMAGE THE LAPTOP USB CONNECTION

IF YOU SMELL BURNING - PULL THE CABLE OUT IMMEDIATELY



Connecting NeoPixels

We will use the same connections for all our projects, for 
simplicity.

Always connect the ground wire first. Then power. Then, 
finally, the data wire.

Ideally, don’t make connections to a live board. Disconnect 
from USB power first.

Take 3 female-female jumper wires. Split them apart a little at 
each end.



Connecting NeoPixels

Connect the ground pin on the Neopixels to GND on the 
Feather Huzzah.

Connect the 5V power in on the Neopixels to 3V (or 3V3) on 
the Feather Huzzah.

Connect Data In on the NeoPixels to pin 14 on the Feather 
Huzzah.

NeoPixels : ESP8266
GND <-> GND

5 V <-> 3V3
Data In <-> Pin 14



First NeoPixel Program

In Arduino, open 
File → Examples → Adafruit NeoPixel → simple

This is a very simple Arduino program for testing NeoPixels.

Before we can run it, we need to make some changes.

 #define PIN 6

Should be changed to:

#define PIN 14

It sets which pin is used to send commands, and we have 
connected the wire for that to pin 14.



Choosing lights

You might have a ring of 16 NeoPixels, a ring of 12 or a stick of 8. These all require 
slightly different settings for NUMPIXELS and for the LED type. (GRB or GRBW)

For the ring of 16:
#define NUMPIXELS      16

Adafruit_NeoPixel pixels = Adafruit_NeoPixel(NUMPIXELS, 
PIN, NEO_GRB + NEO_KHZ800);

For the ring of 12:
#define NUMPIXELS      12

Adafruit_NeoPixel pixels = Adafruit_NeoPixel(NUMPIXELS, 
PIN, NEO_GRBW + NEO_KHZ800);



Choosing lights

You might have a ring of 16 NeoPixels, a ring of 12 or a stick of 8. These all require 
slightly different settings for NUMPIXELS and for the LED type. (GRB or GRBW)

For the stick of 8:
#define NUMPIXELS      8

Adafruit_NeoPixel pixels = Adafruit_NeoPixel(NUMPIXELS, 
PIN, NEO_GRBW + NEO_KHZ800);

! REMEMBER TO CHANGE THIS AS THE FIRST STEP IN ANY NEW PROGRAM. 
WRONG PIN ASSIGNMENTS CAN DAMAGE HARDWARE. !



Final modification - brightness

The NeoPixels can be really, really bright. Bright enough to 
hurt your eyes.

To start safe, change the brightness from 150 to 20:

pixels.setPixelColor(i, pixels.Color(0,20,0)); 

Upload the program by clicking the right-arrow at the top left 
of the Arduino window.

After compiling and uploading, the lights should do 
something…

Disconnect and reconnect the USB to restart the board and 
watch again.



Challenge 2

Can you change the colour displayed by the lights to red? 
To blue? 
To yellow?

Hint: the three numbers in pixels.setPixelColor() are the 
brightnesses of the red, green and blue LEDs in each pixel.

(Harder) Can you modify the program to just light up 1 LED at 
a time?



Analysis of the program, from the 
top down

#include <Adafruit_NeoPixel.h>
Includes the NeoPixel libraries which give us useful
functions for controlling the LEDs.

Adafruit_NeoPixel pixels = 
Adafruit_NeoPixel(NUMPIXELS, PIN, NEO_GRB + 
NEO_KHZ800);

Creates an object called “pixels” that represents the LED
string. We will use this object to control the LEDs.

 pixels.begin(); 
Initialises the pixels and gets them ready to accept 
commands



Analysis of the program, from the 
top down

pixels.setPixelColor(i,pixels.Color(0,20,0));
Sets the colour of pixel i to red=0, green=20, blue =0.
This changes the state of the pixel in the computer
memory. This does not actually change the LED colour.

pixels.show();
Updates the LEDs with all the new colours that have been
set since this function was last called. This is the part
where the LEDs actually change colour.



For loops in Arduino

The code includes a for loop, which looks like this:

for(int i=0;i<NUMPIXELS;i++){
pixels.setPixelColor(i, pixels.Color(0,20,0)); 
pixels.show(); 
delay(delayval);

  }

The for loop reads: “create an integer called i and set it to zero. While i is less than 
NUMPIXELS, run the code below then add 1 to i and repeat. If i is not less than 
numpixels, move on to the next block of code.”

It is a way of looping through every pixel in the setup.

“++” after a variable is a short way of adding 1 to it, called “increment”. This is the “joke” in the name of the 

programming language C++. It’s one better than C.



NeoPixel Assignment 1

Can you change the program so that each light lights up a 
different colour?

Hint: don’t set a fixed value for red, green and blue, but make the 
values depend on i…

e.g. (20-i, 0, 2*i) for (r,g,b) - find your own pattern that you like.

Save your .ino file and upload it to the classroom. Put your names 
in a comment at the top of the program.



Neopixel animations

So far, we have used a for loop to update one pixel at a time.

To get better animations, we can update all the pixels at once.

To do this, we will make three changes:

1. Move pixels.show() outside the for loop, so it only 
updates when all the pixels have been changed by the 
program.

2. Move the delay() outside the for loop as well, so there 
is no delay inside the for loop to slow down the 
animation.

3. Create a “loop counter” that we can use for our 
animation.



Neopixel Animations

First, move the delay and pixels.show() outside the for loop:

void loop() {
// For a set of NeoPixels the first NeoPixel is 0, second is 1, all the way up to the count of pixels minus one.
for(int i=0;i<NUMPIXELS;i++){

// pixels.Color takes RGB values, from 0,0,0 up to 255,255,255
pixels.setPixelColor(i, pixels.Color(0,20,0)); // Moderately bright green color.

}
pixels.show(); // This sends the updated pixel color to the hardware.
delay(delayval); // Delay for a period of time (in milliseconds).

}



Neopixel Animations

Next, add the loop counter.

Before using a variable in Arduino, you first have to declare its name and its type.

So before the setup() function, after int delayval = 500; add the following line:

int n = 0;

This creates an integer (whole number) variable called “n” and sets it to zero.

Don’t forget the semicolon!

While you’re here, change delayval to 20. A 20 millisecond delay means 50 
updates per second for smooth animation.



Neopixel Animations

Now we want to increment n every time we go round the whole loop.

Add the line shown in red:

void loop() {
// For a set of NeoPixels the first NeoPixel is 0, second is 1, all the way up to the count of pixels minus one.
for(int i=0;i<NUMPIXELS;i++){

// pixels.Color takes RGB values, from 0,0,0 up to 255,255,255
pixels.setPixelColor(i, pixels.Color(0,20,0)); // Moderately bright green color.

}
pixels.show(); // This sends the updated pixel color to the hardware.
delay(delayval); // Delay for a period of time (in milliseconds).
n = n+1;

}



The modulo operator %

Our loop counter will keep getting bigger and bigger. But what 
if we want our animation to repeat?

The modulo operator is a good way to make this happen. 
Modulo means “the remainder after division”.

So:

7%5 = 2
10%5 = 0
18%15 = 3
42%7 = 0

and so on.



Looping animation 1

Change the last line you inserted from n = n+1 to

n = (n+1)%NUMPIXELS;

Now n will count up from 0 to NUMPIXELS-1 (7,11 or 15 
depending on what you set it to) then go back to zero and 
count up again.

0,1,2,3,4,5,6,7,8,9,10,11,0,1,2,3,4,5,6,7,8,9,10,11,0,1,2,3…… 



Looping animation 2

Update the code inside the loop to this:

void loop() {

  for(int i=0;i<NUMPIXELS;i++){  
    pixels.setPixelColor(i, pixels.Color(0,0,0)); // All pixels off 
  }

  pixels.setPixelColour(n,12,0,12); //just set pixel n to purple
  pixels.show(); // This sends the updated pixel color to the hardware.
  delay(delayval); // Delay for a period of time (in milliseconds).
  n = (n+1)%NUMPIXELS;

}

Upload to the ESP8266 board. A single, purple light should be moving rapidly 
around.



Assignment 2

Invent your own interesting animation pattern for your 
NeoPixels.

You can load the strandtest example, or the example .ino files 
on Google Classroom for some ideas  - remember to change 
NUMPIXELS and the GRB/RGBW settings to match your 
lights, and #define PIN to 14 before uploading to the board. 

You can also look for Youtube videos of NeoPixel projects for 
more ideas.

Upload your working .ino file to Google Classroom. Put your 
names in a comment at the top of the source code.



Hints for assignment 2

If you make the colour depend on i, each pixel will be a 
different colour.

If you make the colour depend on n, the colour will change 
over time.

If you want a moving pattern, the colour will have to depend 
on both n and i, somehow.

There are lots of ways of doing this. You could add n and i together, modulo 

numpixels: (n+i)%numpixels to choose which pixel to set which colour.

Or you could make the formulas for the colours depend on both n and i.

There are many, many ways. The strandtest built-in example (File → Examples 

→ Neopixels → strandtest) includes other ways of animating the lights.




